HDU 胜利大逃亡(BFS)
HDOJ 1253 胜利大逃亡 (BFS)
Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.
魔王住在一个城堡里,城堡是一个ABC的立方体,可以被表示成A个B*C的矩阵,
刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,
Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.
现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.
Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块…),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫) 特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.
Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0
Sample Output
11
BFS
BFS的核心思路就是对象状态的转移。给了你初始节点、终止节点、生成子节点的约束条件,求对象转移状态总共花费的最小代价。对于本题,Ignatius的初始状态是(0,0,0)目标状态是(A – 1,B – 1,C – 1),状态转移的约束条件是:
- 不能超出迷宫的范围
- 迷宫是1的地方不能走
- 走过的地方不要走(减枝)
最后考虑bfs的出口:走到出口并且没有超过魔王外出的时间!
总结:不同的题目只不过是状态转移的方式和离开的条件不同,思路大致是相同的。
状态结点
struct node
{
int x,y,z;
int step;
};
初始状态生成
memset(vis,0,sizeof(vis)); //需要include<cstring>,把数组置0,表示迷宫所有结点未被走过
node Now,next; //需要两个表示状态的结点,分别用于存储当前状态和下一个状态
Now.x = Now.y = Now.z = Now.step = 0;
vis[0][0][0] = 1;
queue<node> q; //队列用来保证步数小的状态一定比步数大的状态先出队
q.push(Now);
循环出口
if(Now.x == A - 1&& Now.y == B - 1 && Now.z == C - 1)
{
if (Now.step <= time)
{cout << Now.step << endl;
return ;}
else{
cout << -1 << endl;
return ;
}
}
状态转移,判断部分可以写成一个函数
for(int i = 0;i < 6; i++){
next.x = Now.x + dir[i][0];
next.y = Now.y + dir[i][1];
next.z = Now.z + dir[i][2];
if (next.x>=0&&next.x <= A - 1&&next.y>=0&&next.y <= B - 1&&next.z >= 0 && next.z <= C - 1 &&Maze[next.x][next.y][next.z] != 1&&!vis[next.x][next.y][next.z])
{
next.step = Now.step + 1;
vis[next.x][next.y][next.z] = 1;
q.push(next);
}
}
完整代码
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int Maze[51][51][51]; //存储迷宫
int vis[51][51][51]; //存储该状态是否来过了
int dir[6][3] = {{1,0,0},{0,0,1},{-1,0,0},{0,0,-1},{0,1,0},{0,-1,0}}; //状态转移数组
int A, B, C, time;
struct node
{
int x,y,z;
int step;
};
void BFS(){
memset(vis,0,sizeof(vis));
node Now,next;
Now.x = Now.y = Now.z = Now.step = 0;
vis[0][0][0] = 1;
queue<node> q;
q.push(Now);
while (!q.empty()) {
Now = q.front();
q.pop();
if(Now.x == A - 1&& Now.y == B - 1 && Now.z == C - 1)
{
if (Now.step <= time)
{cout << Now.step << endl;
return ;}
else{
cout << -1 << endl;
return ;
}
}
for(int i = 0;i < 6; i++){
next.x = Now.x + dir[i][0];
next.y = Now.y + dir[i][1];
next.z = Now.z + dir[i][2];
if (next.x>=0&&next.x <= A - 1&&next.y>=0&&next.y <= B - 1&&next.z >= 0 && next.z <= C - 1 &&Maze[next.x][next.y][next.z] != 1&&!vis[next.x][next.y][next.z])
{
next.step = Now.step + 1;
vis[next.x][next.y][next.z] = 1;
q.push(next);
}
}
}
cout << -1 << endl;
}
int main() {
int T;
cin >> T;
while(T--) {
cin >> A >> B >> C >> time;
for(int i = 0;i < A;i++){
for(int j = 0; j < B; j++){
for(int k = 0; k < C; k++) {
scanf("%d",&Maze[i][j][k]);
}
}
}
BFS();
}
}